Getting Started

Revision as of 06:13, 9 May 2020 by MoKaLux (talk | contribs) (navigatiion)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

The Ultimate Guide to Gideros Studio

Gideros Studio IDE: Basics

When you start Gideros Studio, it opens in the welcome mode and shows the dashboard. Here you can do the following:

  • Create and open projects
  • Read Getting Started Guide
  • Read Reference Manual
  • Open all recent projects and sessions
  • Open tutorials and 30+ example projects

Menu organization

Gideros Studio is a very simple and easy-to-use IDE. The menu organization is also straightforward and easy to understand. Here is what each menu do:

  1. File menu: Where you open, save, close a project. This is also the place where you export your code to Android Studio or XCode, etc.
  2. Edit menu: Provides editing functionalities like undo, redo, cut, copy, paste, find and more.
  3. Compile menu: Checks the syntax of your code, by compiling the project and writing the possible errors to the output console.
  4. Player menu: Launches the Gideros Player on the desktop, sends an application to the Gideros Player (on the desktop and/or the mobile device). If you want to test your application on your device, you need to install the Gideros Player application.
  5. Help menu: Includes links to the Gideros Community Forum and the Gideros Documentation.

Note that you can reach any menu item using its corresponding shortcut.

Project pane

The Library panel on the left, shows the project files, including all Lua files and assets like graphics and sound. All files added to the project can be seen here.

To add a Lua file to your project, right click on Files and choose "Add a new file". If you already have an existing file (e.g. Lua, PNG, JPEG, etc) then click "Add existing file" instead.

ProjectPane.png

Output pane

The output pane will give you valuable information when you run your project in a player. For one, you will see which assets are transferred to the player. For two, you will see error messages from Lua in the output pane:

OutputPane.png

Code pane

The code pane is where you type your Lua code. It supports syntax color highlighting.

Codearea.png

File tabs

For every file you have currently opened in Gideros Studio, there will be a tab with its name above the code area.

Codearea2.png

To navigate between these files, just click on the name and the code area will change to this file. If you want to close the file, just click on the little X next to the name of the file.

Bookmarks

If you have bookmarked a line or more in your code, the gutter on the left, which shows the line numbers by default, will show little triangles to indicate that a bookmark was set there:

Bookmarks.png

To set, remove and navigate between the bookmarks, use the icons Bookmarks2.png on the toolbar.

Autocompletion

The code pane of Gideros Studio also supports code completion. Depending on what you type in, it will make suggestions on what could be inserted and you can choose from a list box a method/function that you would like to use.

Autocompletion.png

If you don’t want that, just press the escape key and the box will close automatically.

Gideros Studio IDE keyboard shortcuts

Some functionality of Gideros Studio and the code area can be reached via shortcuts. Here is a list of currently supported shortcuts:

General key bindings

Note: Under Mac OS X, use Command button instead of Control.

   • Control - N : New project
   • Control - O : Open project
   • Control - Q : Exit
   • Control - F : Find
   • Control - H : Replace
   • Control - G : Go to line
   • Control - W : Quit
   • Control - U : Make all lowercase
   • Control - L : Delete line
   • Control - T : Swap the current line with the line above it
   • Control - D : Duplicate the current line
   • Control - S : Save current file
   • Control - A : Select all
   • Control - Z : Undo
   • Control - Y : Redo
   • Control - X : Cut
   • Control - C : Copy
   • Control - V : Paste
   • Control - B : Compile
   • Control - R : Start
   • Control - + : Increase font size
   • Control - - : Decrease font size
   • Control - Tab : Switch to next tab
   • Control - Shift - U : Make all UPPERCASE
   • Control - Shift - R : Stop
   • Control - Shift - P : Start local player (starts desktop player with IP = 127.0.0.1)
   • Control - Shift - F : Find in files
   • Control - Shift - B : Compile all
   • Control - F2 : Toggle bookmark
   • F2 : Go to next bookmark
   • Shift - F2 : Goto previous bookmark
   • F3 : Find next
   • Shift - F3 : Find previous

Specific Mac OS X key bindings for navigation

(command button)

   • command + left: start of line
   • command + right: end of line
   • command + up: beginning of document
   • command + down: end of document
   • command + backspace: delete line to the left

(option button)

   • option + left: move to next word on the left (case insensitive)
   • option + right: move to next word on the right (case insensitive)
   • option + backspace: delete word to left

(control button)

   • control + left: move to next word on the left (case sensitive)
   • control + right: move to next word on the right (case sensitive)
   • control + up: page up
   • control + down: page down
   • control + backspace: delete word to left (same with option + backspace)


PREV.: Gideros Studio
NEXT: Gideros Player